ICMPv4 Constant Enumerations¶
This module contains all constant enumerations of
ICMPv4 implementations. Available
enumerations include:
ICMP Type Numbers [*] |
|
ICMP Destination Unreachable Codes [†] |
|
ICMP Time Exceeded Codes [‡] |
|
ICMP Parameter Problem Codes [§] |
ICMP Type Numbers¶
This module contains the constant enumeration for ICMP Type Numbers,
which is automatically generated from pcapkit.vendor.icmp.type.Type.
- class pcapkit.const.icmp.type.Type(*values)[source]¶
Bases:
EnumRegistry,aenum.IntEnum[Type] ICMP Type Numbers [RFC 792]
- Unassigned_1 = 1¶
Unassigned
- Unassigned_2 = 2¶
Unassigned
- Unassigned_7 = 7¶
Unassigned
- Reserved_19 = 19¶
Reserved (for Security) [Solo]
- ICMP_messages_utilized_by_experimental_mobility_protocols_such_as_Seamoby = 41¶
ICMP messages utilized by experimental mobility protocols such as Seamoby [RFC 4065]
- Reserved_255 = 255¶
Reserved [JBP]
- classmethod _validate_value(value)[source]¶
Reject
valueunless it passes the range check_missing_()makes.Overrides
_validate_value()with that check and the message it raises, soregister()refuses exactly the valuesget()refuses, in the same words (#1816).- Parameters:
value (
Any) – Value about to be looked up or minted.- Raises:
EnumValueError – If
valuefails that check. AValueError, so anexcept ValueErrorcaller is unaffected.
ICMP Destination Unreachable Codes¶
This module contains the constant enumeration for ICMP Destination
Unreachable Codes, which is automatically generated from
pcapkit.vendor.icmp.destination_unreachable_code.DestinationUnreachableCode.
- class pcapkit.const.icmp.destination_unreachable_code.DestinationUnreachableCode(*values)[source]¶
Bases:
EnumRegistry,aenum.IntEnum[DestinationUnreachableCode] ICMP Destination Unreachable Codes [RFC 792]
- Fragmentation_Needed_and_Don_t_Fragment_was_Set = 4¶
Fragmentation Needed and Don’t Fragment was Set [RFC 792]
- Communication_with_Destination_Network_is_Administratively_Prohibited = 9¶
Communication with Destination Network is Administratively Prohibited [RFC 1122]
- Communication_with_Destination_Host_is_Administratively_Prohibited = 10¶
Communication with Destination Host is Administratively Prohibited [RFC 1122]
- Destination_Network_Unreachable_for_Type_of_Service = 11¶
Destination Network Unreachable for Type of Service [RFC 1122]
- Destination_Host_Unreachable_for_Type_of_Service = 12¶
Destination Host Unreachable for Type of Service [RFC 1122]
- Communication_Administratively_Prohibited = 13¶
Communication Administratively Prohibited [RFC 1812]
- classmethod _validate_value(value)[source]¶
Reject
valueunless it passes the range check_missing_()makes.Overrides
_validate_value()with that check and the message it raises, soregister()refuses exactly the valuesget()refuses, in the same words (#1816).- Parameters:
value (
Any) – Value about to be looked up or minted.- Raises:
EnumValueError – If
valuefails that check. AValueError, so anexcept ValueErrorcaller is unaffected.
ICMP Time Exceeded Codes¶
This module contains the constant enumeration for ICMP Time Exceeded
Codes, which is automatically generated from
pcapkit.vendor.icmp.time_exceeded_code.TimeExceededCode.
- class pcapkit.const.icmp.time_exceeded_code.TimeExceededCode(*values)[source]¶
Bases:
EnumRegistry,aenum.IntEnum[TimeExceededCode] ICMP Time Exceeded Codes [RFC 792]
- Time_to_Live_exceeded_in_Transit = 0¶
Time to Live exceeded in Transit
- Fragment_Reassembly_Time_Exceeded = 1¶
Fragment Reassembly Time Exceeded
- classmethod _validate_value(value)[source]¶
Reject
valueunless it passes the range check_missing_()makes.Overrides
_validate_value()with that check and the message it raises, soregister()refuses exactly the valuesget()refuses, in the same words (#1816).- Parameters:
value (
Any) – Value about to be looked up or minted.- Raises:
EnumValueError – If
valuefails that check. AValueError, so anexcept ValueErrorcaller is unaffected.
ICMP Parameter Problem Codes¶
This module contains the constant enumeration for ICMP Parameter Problem
Codes, which is automatically generated from
pcapkit.vendor.icmp.parameter_problem_code.ParameterProblemCode.
- class pcapkit.const.icmp.parameter_problem_code.ParameterProblemCode(*values)[source]¶
Bases:
EnumRegistry,aenum.IntEnum[ParameterProblemCode] ICMP Parameter Problem Codes [RFC 792][RFC 1108]
- Pointer_indicates_the_error = 0¶
Pointer indicates the error
- Bad_Length = 2¶
Bad Length
- classmethod _validate_value(value)[source]¶
Reject
valueunless it passes the range check_missing_()makes.Overrides
_validate_value()with that check and the message it raises, soregister()refuses exactly the valuesget()refuses, in the same words (#1816).- Parameters:
value (
Any) – Value about to be looked up or minted.- Raises:
EnumValueError – If
valuefails that check. AValueError, so anexcept ValueErrorcaller is unaffected.
Footnotes